Images in Adobe Lightroom Classic can easily be handed off to Luminar Neo for editing. To send a file from Lightroom Classic to Luminar Neo, follow these steps:

  1. Open Adobe Lightroom Classic.
  2. In Lightroom Classic, choose the image you want to work with within Luminar Neo from the Library or Develop module.
  3. Send your image to Luminar Neo using one of the following methods:

Photo menu

  1. Choose Photo > Edit In > Luminar Neo. A new dialog box will open.
  2. Choose one of these options:

  • Edit a Copy with Lightroom Adjustments — Sends a high-quality file to Luminar Neo based on the edits you’ve made in Lightroom. You can choose options for this exported file at the bottom of the window.
  • Edit a Copy — Sends a high-quality file based on the original image (does not work for raw files).
  • Edit Original — Modifies the original file on your hard drive and ignores Lightroom adjustments. This option does not work for raw files.
  1. Select any additional Copy File Options, then click Edit.

Note: If Luminar Neo is missing from the Photo > Edit in the menu, open Lightroom preferences. Select the Presets tab and UNCHECK the option for Store presets with this catalog.

Right-click option

  • Right-click on the image > Export > Luminar Neo > You have an option to Open Source Files or, if you’ve made any changes in Lightroom that you’d like to transfer over to Luminar Neo, you can also choose to Edit a Copy with Lightroom Adjustments.
  • After applying adjustments in Luminar Neo, your photo should appear in Lightroom’s Catalog > All Photographs.

File menu

  • File > Export with Preset > Luminar Neo Edit a Copy with Lightroom Adjustments — Sends a high-quality file based on the edits you’ve made in Lightroom.
  • File > Export with Preset > Luminar Neo Open Source Files — Sends the original file (without Lightroom edits) to Luminar Neo.
  • File > Plug-in Extras > Transfer to Luminar Neo — Transfers the original file to Luminar Neo for editing. This option is ideal for sending a raw file to Luminar Neo so you have the maximum data to work with.

Editing in the Luminar Neo plug-in

Once the file is sent, you’re ready to edit.

  1. If needed, click the Luminar Neo icon in your Dock or Taskbar to switch to Luminar Neo.
  2. Make edits or adjustments as desired in Luminar Neo.
  3. When done, click the Apply button to send the adjusted image back to Lightroom Classic.

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Please do not use this for support questions.
Skylum Customer Service

Post Comment