Images in Adobe Lightroom Classic can easily be handed off to LuminarAI for editing. To send a file from Lightroom Classic or Lightroom CC to LuminarAI, follow these steps:

  1. Open Adobe Lightroom Classic/CC.
  2. In Lightroom Classic/CC, choose the image you want to work with within LuminarAI from the Library or Develop module.
  3. Send your image to LuminarAI using one of the following methods:

Photo menu

  1. Choose Photo > Edit In > LuminarAI. A new dialog box will open.
  1. Choose one of these options:

  • Edit a Copy with Lightroom Adjustments — Sends a high-quality file to LuminarAI based on the edits you’ve made in Lightroom. You can choose options for this exported file at the bottom of the window.
  • Edit a Copy — Sends a high-quality file based on the original image (does not work for raw files).
  • Edit Original — Modifies the original file on your hard drive and ignores Lightroom adjustments. This option does not work for raw files.
  1. Select any additional Copy File Options, then click Edit.

Note: If LuminarAI is missing from the Photo > Edit in the menu, open Lightroom preferences. Select the Presets tab and UNCHECK the option for Store presets with this catalog.

File menu

  • File > Export with Preset > LuminarAI Edit a Copy with Lightroom Adjustments — Sends a high-quality file based on the edits you’ve made in Lightroom.
  • File > Export with Preset > LuminarAI Open Source Files — Sends the original file (without Lightroom edits) to LuminarAI.
  • File > Plug-in Extras > Transfer to LuminarAI — Transfers the original file to LuminarAI for editing. This option is ideal for sending a raw file to LuminarAI so you have the maximum data to work with.

Editing in the LuminarAI plug-in

Once the file is sent, you’re ready to edit.

  1. If needed, click the LuminarAI icon in your Dock or Taskbar to switch to LuminarAI.
  2. Make edits or adjustments as desired in LuminarAI and use Templates to speed up your editing workflow.

  1. When done, click the Apply button to send the adjusted image back to Lightroom.

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Please do not use this for support questions.
Skylum Customer Service

Post Comment